×
Retirement and forum shutdown (17 Jan 2022)

Hi,

John Howell who has managed the forum for years is getting on and wishes to retire from the role of managing it.
Over the years, he has managed the forum through good days and bad days and he has always been fair.
He has managed to bring his passion for fish keeping to the forum and keep it going for so long.

I wish to thank John for his hard work in keeping the forum going.

With John wishing to "retire" from the role of managing the forum and the forum receiving very little traffic, I think we must agree that forum has come to a natural conclusion and it's time to put it to rest.

I am proposing that the forum be made read-only from March 2022 onwards and that no new users or content be created. The website is still registered for several more years, so the content will still be accessible but no new topics or replies will be allowed.

If there is interest from the ITFS or other fish keeping clubs, we may redirect traffic to them or to a Facebook group but will not actively manage it.

I'd like to thank everyone over the years who helped with forum, posted a reply, started a new topic, ask a question and helped a newbie in fish keeping. And thank you to the sponsors who helped us along the away. Hopefully it made the hobby stronger.

I'd especially like to thank John Howell and Valerie Rousseau for all of their contributions, without them the forum would have never been has successful.

Thank you
Darragh Sherwin

Hello there and can anyone help

More
05 Dec 2020 20:24 #1 by Stukin
Hey there, brand new to this site and hoping for some help. Have a freshwater tank 55l for some years now. Back in Feb bought some new fish and unfortunately tipped water from the bag into tank which had little red hair like worms (only noticed after), a few weeks later I noticed what I think were nematodes (white maggots) looking to climb up above the water line. If there is condensation on occasion above the water line you could see minute little organisms moving from the plastic frame leaving trails on the glass. Over time treated the water with esha ndx and gdx, prime, algae stablizers but unfortunately lost all fish in time. What's the best way to disinfect the tank fully before starting all over again ?? Any help greatly appreciated.

Please Log in to join the conversation.

Time to create page: 0.057 seconds
Powered by Kunena Forum